EVA bot is crashing with following error


While running the bot , Bot is getting crash with followed errors [ Error info : Attached ]

Hi Anil,

Is it happening when you are running some process. If yes, request to please provide details of process as in what activity have been used in the process


Eva bot is crashing during start up. It is not running any automation script. It fails at startup of bot. The Assist Edge CE UI is running fine, though.


Is it happening always or intermittently. Kindly attached EVA bot logs in order to analyze further


almost always… in past 4 days, it worked only one day. three days it didnt start up.

how do I attach log? got error saying .log not valid extn. Copy pasting the log says, 32K limit crossed.


Just paste the exception and error in logs here

Pasting only todays log.


There are no exception in the logs. Is this the log when your EVA bot crashed

Yes. This is todays Log. When EVA bot crashes, the log timestamp changes, but as you observed no error/exception, just pop up message. The Error pop image is pasted in top of the thread.


Open eventviewer by typing eventvwr in run window and check Windows Logs > Application. Check for error thr and paste the same for PA bot

Log Name: Application
Source: Application Error
Date: 1/28/2019 6:05:38 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: ae-win-2012
Faulting application name: RoboSE.exe, version:, time stamp: 0x5ba80117
Faulting module name: KERNELBASE.dll, version: 6.3.9600.19178, time stamp: 0x5bc10573
Exception code: 0xe0434352
Fault offset: 0x00015ef8
Faulting process id: 0xeec
Faulting application start time: 0x01d4b6cf76fbf15b
Faulting application path: C:\Users\aepoc\Documents\EdgeVerve Systems Limited\AssistEdge_CE\PA\RoboSE.exe
Faulting module path: C:\Windows\SYSTEM32\KERNELBASE.dll
Report Id: bb7ae1bd-22c2-11e9-80d9-000d3a58bd0c
Faulting package full name:
Faulting package-relative application ID:
Event Xml:



C:\Users\aepoc\Documents\EdgeVerve Systems Limited\AssistEdge_CE\PA\RoboSE.exe


The 0xe0434352 error may be caused by windows system files damage. The corrupted system files entries can be a real threat to the well being of your computer.
There can be many events which may have resulted in the system files errors. An incomplete installation, an incomplete uninstall, improper deletion of applications or hardware. It can also be caused if your computer is recovered from a virus or adware/spyware attack or by an improper shutdown of the computer. All the above actives may result in the deletion or corruption of the entries in the windows system files. This corrupted system file will lead to the missing and wrongly linked information and files needed for the proper working of the application.


Suggestion - > Uninstall and reinstall the application

Same issue after reinstalling.

The Eva bot crashed again today morning after overnight shutdown of VM.

i tried to post more info on the error, but my post has been hidden by bot as spam. Let me know how can i send error details, if we cannot attach or post.


Was it working before overnight shutdown of VM .


Yes. The EVA bot started fine after reinstall. Though i did not publish any activity to EVA bot yet, today morning after VM started it failed to open.


I think some crtical files required by EVA bot are getting deleted / blocked post VM start as per your machine policy.

For debugging purpose, try to re deploy AssistEdge post uninstallation. Ensure that it works end to end.
Make a copy of deployed folder f and keep it in your local desktop as back up
Restart your VM and see if EVA bot works or not. If it doesn’t now compare your local copied folder with the one in server. You will get to know which file is mising

ok… here is the .Net Runtime error
Application: RoboSE.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Xml.XmlException
at System.Xml.XmlTextReaderImpl.Throw(System.Exception)
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlTextReader.Read()
at System.Xml.XmlReader.MoveToContent()
at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderBindableCollection1.Read3_ArrayOfWatcherConfiguration()

Exception Info: System.InvalidOperationException
at System.Xml.Serialization.XmlSerializer.Deserialize(System.Xml.XmlReader, System.String, System.Xml.Serialization.XmlDeserializationEvents)
at System.Xml.Serialization.XmlSerializer.Deserialize(System.IO.TextReader)
at RoboViewModel.ViewModel.PAViewModel.ReadWatcherConfiguration()
at RoboViewModel.ViewModel.PAViewModel+<>c__DisplayClass132_1.b__2()
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
at System.Windows.Threading.DispatcherOperation.InvokeImpl()
at System.Windows.Threading.DispatcherOperation.InvokeInSecurityContext(System.Object)
at MS.Internal.CulturePreservingExecutionContext.CallbackWrapper(System.Object)
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
at MS.Internal.CulturePreservingExecutionContext.Run(MS.Internal.CulturePreservingExecutionContext, System.Threading.ContextCallback, System.Object)
at System.Windows.Threading.DispatcherOperation.Invoke()
at System.Windows.Threading.Dispatcher.ProcessQueue()
at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)
at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)
at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)
at System.Windows.Threading.Dispatcher.PushFrame(System.Windows.Threading.DispatcherFrame)
at System.Windows.Application.RunDispatcher(System.Object)
at System.Windows.Application.RunInternal(System.Windows.Window)
at System.Windows.Application.Run(System.Windows.Window)
at RoboView.App.Main()

Does it provide any clue which file is getting corrupted…? I think, When VM shut down overnight, EVA gets killed and bot doesn’t like it. This will be case in most of Cloud machines. It will suddenly crash or machine gets shutdown and Process respawn as new machine. Is EVA bot tested with this scenario in mind?


Is your VM getting wiped off and OS image restored every night.