Object has been disconnected or does not exist at the server

I am using SAP recorder in my bot to fetch certain records from SAP. But now the number of records have been increased from 100k to 225k and once all the records are being downloaded on my machine in .xlsx file, AE gives the error “Object xxx has been disconnected or does not exist at the server”.
I think report download is taking so much time the bot being idle is getting failed.
Can you pl guide for some resolution ?
Nipun Bhatia


What is the download time that is being taken.


it is taking around 10-12mins…


In ``installation directory\ EdgeVerve Systems Limited\AssistEdge_CE\ACE\Automation Studio.exe.config` file change value of key MultiDomain to false
Also , change value of key StudioSearchTime to more than 10 min. ( which is default value)


Point 1 is done.

for point 2, i have increased following values as shown below, but problem still remains.

add key=“StudioSearchTime” value=“50000000” />
add key=“PermissibleWaitTime” value=“1000000” />

Problem has been resolved by doing above steps. Thank you v much :slight_smile:

I am facing a similar issue in my application where -

  1. Step1 - login to TimeIt application and submit request
  2. Step2 - login to iTime application and approve the request
  3. Step3 - login back to TimeIt application to process further.

The process is failing at step3 as the application has been idle for a long time. To reach till step3 my process is taking nearly 10 mins.

As suggested above, I have changed the config file as follows -

  1. add key=“MultiDomain” value=“false”/>
  2. add key=“StudioResetTime” value=“12000000”/>
  3. add key=“StudioSearchTime” value=“12000000” />
  4. add key=“DefaultProcessWaitTime” value=“12000000” />
  5. add key=“MaxControlWaitTime” value=“12000000” />

But I see no change, facing the same error again. Could you please advice?


May be your application itself is getting timed out. Do not leave the application idle for long time. Alternatively you can close the application at Step2 using close activity and then use Launch and Sign in activity to relaunch application at start of Step 3.

Amit Anand

Hi Amit,
You are right, the application itself is getting timed out. But I could not find any option such as ‘close activity’. Also, for TimeIt application there is no ‘signin activity’ required. However, there is an option called ‘reset activity’ which I have tried in below ways -

  1. Reset at the end of Step1 - this didnt work. There are 2 problems here, firstly the reset takes so long that the error is occuring at in the beginning of Step2 itself saying ‘iTime’ application has disconnected. Secondly, after resetting at step1 the application would have been idle till the control flows to step3, hence failed again.
  2. Reset at the start of Step3 - The flow successfully completed step1&2, reached step3 and executed the ‘reset activity’, but immediately after resetting it is throwing the same error. This is where I am stuck, not sure why it failed. Could you please help?
  3. Duplicate TimeIt application - previously I was connecting/reconnecting to the same application window in step1 and step3. Instead of this, I launched 2 different windows for both steps, but the error remains same. I have used ‘reset activity’ also in 2nd window, but no luck again.



Close Application and Launch Application are part of enterprise edition. Alternatively you can perform some non intrusive activity to prevent your from getting timed out

For reset activity to work you will have to define reset process for the application which has been used in your automation process. In case you did not define reset process then default reset will be called which is navigating application back to Search url defined in properties window

Amit Anand