Will the existing open-source packages works for 18.x and 19.x?

Will the existing open-source packages works for 18.x and 19.x?