Web Field Configuration Failure

community-edition
automation-studio

#1

I am accessing Finacle 7 web application. After clicking on “start field configuration” application controls are not highlighting to select. This happens after installing “java 6 update 34”. Before that, this function worked properly. But java is needed to run this Finacle application. please help me ASAP. this is critical.


#2

this is the relevent part of error log for that issue.

please reach me ASAP.

co_module~SE_ACE inst_key~0 trans_key~0 trans_id~ req_id~ cust_id~ crossref_id~ workspacekey~Default datetime~2019-02-22T16:04:16.715+05:30 level~Error priority~0 srcmodule~EV.AE.IEWebAutomation method~IEPlugin- StartScraping-FinacleHNB errormessage~Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index exceptiondetails~ at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
at EV.AE.IEWebAutomation.IEPlugin.<>c__DisplayClass109_0.b__1()
at Polly.Retry.RetryEngine.Implementation(Action action, IEnumerable1 shouldRetryPredicates, Func1 policyStateFactory)
at Polly.RetrySyntax.<>c__DisplayClass3_0.b__0(Action action, Context context)
at Polly.Policy.Execute(Action action, Context context)
at EV.AE.IEWebAutomation.IEPlugin.StartScraping(Boolean isSignIn) userid~WIN-JULU27E0R3L\sysop ipaddress~10.110.6.118


#3

Hi,

Are you trying to scrap an applet inside a web application which is java based control or a web application control. JDK version supported is 1.7 and 1.8

Regards,
Amit


#4

It is not applet. just web application. I cofigured web application before install JRE. I completed that process. After that I wanted to develop another process for different web application. (Finacle 7). So i installed JRE. After that Web configuration is not working. So i checked the web scraping tool for previous web site (because it worked properly). But now web configuration tool is not working for any website.


#5

Hi,

In order to debug can you try scrapping generic website say google and check. This will help us in isolating if the issue is Finacle Application related

Regards,
Amit


#6

i checked. we cant scrape any web site now. but before it works better.


#7

Hi,

This needs to be checked. Recommended version of of Java is 1.7 onwards

Regards,
Amit


#8

I will install java 1.7 and let you know. Now I have uninstalled all java versions from machine. But still it is not working.
how can you check this. I need further help.


#9

Hi,

For community version you will have to resolve your issue. I can only suggest depending upon inputs you provide. Install JDK 1.7 and then send the logs again

Regards,
Amit


#10

Hi,

Ok I will do it and let you know. And I tried this with enterprice edition and raised a ticket in jira.

Thanks.