None of the Deployed BOT is working whereas it works if executed normal process

I created another Process which is running in background before deploying. i published the BOT. Executed via EVA BOT getting error…

“level”:“Warning”,“priority”:“0”,“srcmodule”:“WorkFlowDataService.ServiceSecurity.AuthenticationManager”,“method”:“BeforeCall”,
“message”:"#EM18: Failed to access the headers in the incoming request.",“description”:“NA”,

I created 4 process and deployed. None of them is responding getting similar error. REquest any one of the team to help here.

Error from EVA BOT
12:08:22 PM : SIGNIN_TRIGGERED : Triggered Sign-in into configured applications.
12:08:23 PM : SIGNIN_COMPLETED : Signin completed with status as success.
12:08:23 PM : AUTOMATION_STARTED : Triggering automation.
12:08:24 PM : PROCESS_STEP : <> failed
12:08:24 PM : AUTOMATION_COMPLETED : Automation execution is completed with status SearchFailed.

Hi,

There is a process step which is failing. First check your process using Debug Process feature in Studio and identify / correct reason of failure of process step

Regards,
Amit

Hi Hemamalini,
Greetings!

Kindly check if you have configured headers for the input excels correctly.

Thanks and Regards,
Archana

i don’t have any input excel for this automation :frowning:

Hi Amit,
I have tested using Set up - Run and Set-up - Debug… All this automation working without any issue. Issue comes only after deploying. while running BOT chrome should be opened that is not opening, i feel as a result first step is failing. But all works fine if i run individually or deploy in other system. what could be the reason of the issue.?

Hi @hemamalini_mohan

I can see you’re creating web automation using Chrome Browser. I feel, the issue in your case is of Chrome Drivers which are not updated.
In Automation Studio if you’re getting the Warning of Chrome Browser Compatibility, then definitely first try updating your Chrome Drivers.

Follow the below steps to update your Chrome Drivers.

  1. Verify the browser version of Chrome.
  2. Verify the compatible web driver on the web.
  3. To achieve compatibility for Studio, navigate to \ACE\SeleniumDrivers path
  4. Create the folder with the name of the driver version - Example - 89.0.4389.23
  5. Update the configuration file with the browser and driver entries. The file path is given below.
    Automation Studio path: \ACE\ApplicationAutomationMetadata.json
  6. Eg: If we are adding an entry for driver 89.0.4389.23 then we need to make a ComponentSpecifics json entry under the ComponentName
    “chrome”. We need to specify following details: -
    a. “ThirdPartyVersion”: “89.0.4389.23”
    b. “CompatibleComponentWithThirdParty”: {“MinVersion”: “89”,“MaxVersion”: “89”}
    c. We also need to add the chrome version supported by added driver in the section SupportedVersions
    • “SupportedVersions”: [“61”,“62”,“63”,“64”,“65”,“66”,“67”,“68”,“89”]
  7. Find the user specific RootDirectory folder (localappdata). Within this find the EdgeVerve folder. Inside EdgeVerve, find the ACE/ProtonFiles folder and inside this folder, delete the SeleniumDrivers folder and ApplicationAutomationMetaData.json file and restart the studio.

I faced similar issue and followed above steps. After restarting my machine everything worked fine.
Please mark this answer as solution if this works for you.