Migration - multiple versions on same server

Hi,
Can you run 18.1 and 19.0 setup on same server? Additionally, is there any LB level change required?