Getting error on using Excel Recorder

I am getting an error message while trying to use Excel Recorder. Can anyone suggest me a solution please. Thanks.

Hi Suwal,

Request to please ensure that you have enabled Trust Access to VBA Project Model in Excel Options > Trust Center Settings > macro Settings. Also, enable macro resording as shown in screenshot

Kindly let me know if it works post that

Hi @amit_anand15,
I have already tried this solution. But it is still showing the same error message. Is there any other solution? Thank you for your help.

Hi Suwal,
In your machine check path C:\windows\assembly and look for file Microsoft.Vbe.Interop. Check its version number.It should be

Also, What is the version of Excel you are trying to record. Current supported version are 2013 and 2016.



I have a similar problem but in my case when I click “Open in Studio”, it does not open.
I have already checked these solutions above:

  • Enable and Trust Macros - checked.
  • Microsoft.Vbe.Interop - checked.

Office 2013
Excel Recorder > Start > Something > Save > Stop Record > Open in Studio.

And it still doesn’t open. I am doing something wrong? Could anyone help me? Please.