Find by - not working

automation-studio
#1

Hi,
I am using the Community Edition to learn AE. However, I am getting stuck while performing the following task:

  1. Open Internet Explorer/Firefox/Chrome.
  2. Type https://google.com
  3. Click on the search text box
  4. Type some text like “Hello”
  5. Hit “Enter” key or click on "Google search.
    The last step is where I am running into issues. Whatever I tried is not working. I tried using various values for the “Find by” option such as: id, name, css3selector, manual, but none of them work.
    Can someone tell me what I am doing wrong please?

Thanks,
Ananth.

#2

Dear User,

Try to use Find By Name on Google search box and search button as shown in attached screenshots.

image

image

Thanks,
Sachin

#3

Using name also does not work. Please see attached screenshot. I am trying to send a “Enter” button, but process is stuck at end of the word.

#4

Hi,
Configure your Google Srch Text box and srch btn as per screenshots below. This will resolve your issue

#5

When you type in the Google search box, the “Google Search” button is hidden by the results. Only the button that appears below the search results can be clicked and even that is not working.

input type=“button” value=“Google Search” class=“lsb”

Can we have a call to get this resolved please?

#6

Hi,

You don’t need to worry about auto suggestion population. In the screenshot above configure your text box and srch button in exactly same manner. I have verified the same in IE browser and it works.

#7

I tried configuring the text as you had suggested and the click event worked. However, the enter button did not work. Can you tell me why? Screenshots are below:

image

#8

Why are you using Send Keys activity. The same is not required.
Your use case is to set value in text field and then click on Search button. Configure Google Search button with the selector that have been shown in screenshot

#9

But what if there is some other use case where I want to use the key? How can I make that work?

#10

Send Keys activity works best in chrome browser. If Send Keys is not working on some control or in particular use case you can look for an alternative way such as Java Script / image automation approach

#11

I am having the same issue. How can this be resolved?

#12

Hi ,

You can configure Google Search button using this selector after selecting manual.
input[name=‘btnK’][value=‘Google Search’][jsaction=‘sf.chk’]

Refer the screenshot attached in above post

#13

Try configuration as follow. Inserting click interaction to hide auto suggestions.

#14

Still getting the error

image

#15

Which browser and version you are using and how have you configured search text box.

#16

Hi Amit,

I am using Google Chrome Version 70.0.3538.102 (Official Build) (64-bit)

Here is my search text box config:

image.png